Our modules and themes meet all requirements of Magento 2.4.2 & 2.3.6-p1

Our modules and themes meet all requirements of Magento 2.4.2 & 2.3.6-p1

Since last week, the new versions of Magento 2 are available. We talk today about the 2.4.2 and 2.3.6-p1 release.

Before we go to the list of improvements, you have to know that we checked all our themes and modules’ compatibility with the latest release. We affirm the support of all features.

Now let’s move to available updates in many areas.

Magento 2.4.2 features first

Platform Enhancements

  • Compatibility with Composer 1.x and 2.x.
  • Compatibility with Elasticsearch 7.9.x. The latest Magento edition still remains compatible with 7.4.x. Please note, that since Magento 2.4.0, MySQL is no longer used for search. However, we made it possible for you to still use Mysql. Learn more in the The New Magento 2.4 Mysql Search module article.
  • Compatibility with Varnish 6.4.
  • Compatibility with Redis 6.x, and still Redis 5.x.
  • Adobe Stock Integration v2.1.1.

Security updates

Within Magento 2.4.2 Open Source you receive 35 security enhancements aimed at closing RCE and XSS vulnerabilities.

Framework updates

The recent release introduced changes in Core quality. They improved the framework with Import/Export, Catalog, Customer account and some other functional areas.

GraphQL updates

When it comes to improvements in GraphQL For the 2.4.2 release, Magento and Community teams are working toward completing GraphQL coverage for Business to Consumer (B2C) use cases. See details at the official site.

Here the list of some more enhancements of Magento 2.4.2:

  • New role resources in Media Gallery. Now it can deliver web-optimized images in the content.
  • Improvements in API performance.
  • Within the PWA Studio, the Venia development concept supports many different languages, currencies, and the new “My Account” components.
  • New B2B enhancements such as better purchase approvals and support for headless commerce.
  • The Upgrade Compatibility Tool. A powerful solution for Magento Commerce to simplify updates.

For more information, visit the official release page.

Magento 2.3.6 p1

2.3.6-p1 is a security-only patch that provides fixes for vulnerabilities that have been identified in the previous Magento 2.3.6 release. It was recommended to install these fixes to keep the website site up-to-date with the most recent security fixes. So, it was no need to apply the hundreds of functional fixes and enhancements that the full quarterly release provides.

Before applying this patch you have to deploy Magento 2.3.6 and update to PHP 7.3.

List of updated Magento 2 extensions

We released new updates and fixes for two modules to make them compatible with the latest Magento 2.4.2 release.

See FireCheckout 1.25.7, Ajax Pro 1.5.17 and PDF Invoices 1.3.3 versions.

We, in summarizing mentioned above features, recommend upgrading Magento 2 modules and themes to meet the Magento 2.4.2 & 2.3.6-p1 requirements.

You can safely move to the latest modules release as we tested all of them. Customers have expectations of what your website should work like.

In case you have any questions, come on - ask us in the comments.

Leave a Reply